Newer style LM plates are jamming in my press.

The Pro 1000, Load-Master, and the Auto Breech Lock Pro.

Newer style LM plates are jamming in my press.

Postby johnmcd348 » 26 Jul 2020 20

I'm just getting back into reloading after having been away from it for a few years. I bought my LoadMaster back about 2006 and used it to load .45ACP, .38/>357, .380ACP, .308, 303, and .30 Carbine. As part of getting my presses back up and running, I bough a few updated parts and was doing a few improvements to my parts, mainly polishing the old plates and cleaning and re-lubing everything as per Shadowdogs recommendations like I did back when it first came out.

Part of my newer parts included dies and plates to reload 9mm and .40S&W. The plates that I bought were the newer style plates with the solid design under the plate for the Indexer presses against instead of the older type, which only has the 5 small points. I polished the bottom of the plates, as I did to the older plates using jewelers rouge and a polishing felt. I've noticed that these newer plates are very rough to operate in my press and they ted to jam the indexer rod when I am trying to operate it. I haven't tried to actually reload 9mm or .40S&W ammo yet, because I've been busy refilling all my spent 45 and 38/357 cases at the moment.

Is there something I'm doing wrong?
Something I need to look at?
A Modification I need to do?

Thanks ahead for any help or input you give. I appreciate it.

John
johnmcd348
 
Posts: 4
Joined: 26 Jul 2020
Has thanked: 0 time
Been thanked: 1 time
My Press Choice: Progressive
Location: FL

Re: Newer style LM plates are jamming in my press.

Postby Ranch Dog » 27 Jul 2020 06

I had some problems with the new style plates. What my plates were doing where binding because of a slightly smaller diameter of the center hole. I've probably documented it somewhere on the forum, but I would check the difference of the hole diameter of the new vs. the old plates.

Lee had me send them a couple of old plates and the two new plates. On return, the new matched the hole diameter of the old. It did look like I had done the work on my worst day, so if I experience the problem with a new plate, I will dress the hole myself.

My index rod has had no issue going from pins to sprocket.
Michael
Image
User avatar
Ranch Dog
Site Admin
Site Admin
 
Posts: 6067
Joined: 22 Jun 2013
Has thanked: 1428 times
Been thanked: 2708 times
My Press Choice: Progressive
Location: Cuero, TX

Re: Newer style LM plates are jamming in my press.

Postby johnmcd348 » 27 Jul 2020 17

I may have cured it but I haven't loaded any 9mm on it yet. I polished the center shaft and I also made a similar angle grinds on the other 3 sides of the indexer and it seems to have stopped. I'd seen some reports from others that have the newer plates on their older presses and said they were having issues with the shaft having a bearing surface difference because the the thickness differences between the newer units since they sit a little farther down the shaft. I've been sitting here for the past 20 minutes, working the lever and it hasn't bound up yet. Last night and this weekend, I couldn't get more than 3 cycles before it bound up every time. I'll try to load some 9mm later this week and see how it works.

Thanks for the input. If I didn't fix it, I'll give a look at the center hole of the newer plates too.
johnmcd348
 
Posts: 4
Joined: 26 Jul 2020
Has thanked: 0 time
Been thanked: 1 time
My Press Choice: Progressive
Location: FL


Return to Progressive

Who is online

Users browsing this forum: No registered users and 1 guest

  • Advertisement